Volksforum.com

Go Back   Volksforum.com > International > Aircooled technical forums > Karmann Ghia (typ 14 & 34)
User Name
Password
Home Shop FAQ Register Members List Calendar Today's Posts




Reply
 
Thread Tools Search this Thread
  #1  
Old 16-09-2014, 22:07
dustrat dustrat is offline
Forum Newbee
 
Join Date: Oct 2013
Posts: 7
Default Front Suspension Problems

dustrat » Tue Sep 16, 2014 9:02 pm

This problem with front suspension has been driving me up the wall. Since fitting Bugpack poly bushes the suspension goes down and dos'nt come back up. I've had the torsion arms in and out quite a few times and still the same problems. As I got the bushes from VW Heritage in UK I got in touch with them and they sugested a few things and sent me a replacement set just incase the bushes were faulty.No joy just the same. Just in case the grease nipples were causing problems I removed them. I decided to get in touch with Bugpack in states but they said that that they had never had any problems. Those of you who know me will know that have'nt got much hair ,well I have even less now. I was beginning to think that I was putting bushes in wrong. I decided to go on some of the forums to see if any one else has had problems.When I got onto samba I found a lot of people had had the same problems dating back to 2007,but Bugpack said they had never had problems. It seems that the bushes fit OK on to torsion arms but as soon as the bushes are pressed into beam they become tight internally and the only way to cure this is ream them out. I got back onto Bugback and again they denied that they had ever had a complaint.With in an hour of talking to Bugpack I got a PM from Just Paul ,a member of Flat4Dubs ,about a member of Baja club forum dated Sunday 16th Sept who was having the same problems as my self. I will be getting back onto Heritage tomorrow to see about a full refund for these bushes and hopefully a good discount on OE bearings and bushes as I have wasted a lot of time fitting parts not fit for purpose. I'll get back and let you all know outcome.
Robert
Reply With Quote
  #2  
Old 23-10-2014, 22:46
dustrat dustrat is offline
Forum Newbee
 
Join Date: Oct 2013
Posts: 7
Default

Sorry for delay getting back on the subject.VW Heritage were very helpful and took the Bugpack bearings back and gave me an acceptable discount on replacements. The OE bearings arrived and set about fitting them only to find that I still had to ream the composite bushes out, but with the help of local engineering company that did not prove a problem.The suspension is back as it was when it left the factory and I'm very pleased. In retrospect after all the time I wasted and the cost of bearings etc it might have been a lot easier buying a new front axle beam.
Robert
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT +1. The time now is 13:17.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
All rights reserved, Volksforum